Beginners Guide Maya

To be used next to “Learning Maya 5 Foundation”

Juni 2005
Clara Coepijn 0928283
Raoul Franker 1202596
Index

Index 1

Introduction 2

The Interface 3

Main Shortcuts 4

Building a Character 5
  Character Animation 5
  Building a skeleton using skeleton joints 5
  Adding a geometry to the skeleton 6
  Adding flexors to the character 7
  Duplicating (parts of) the character 7
  Selection handles 7
  Expressions 7
  Rotate plane IK solver rotation 8
  Vector constraints 8
  Character Nodes 8
  Animation: keyframing and positioning 9

Animating the Character 10
  Non-Linear Animation 10
  Non-destructive Keys 11
  Animating a Camera and Aim 11
  Maya Embedded Language (Mel) 11

Rendering the scene 12
  Creating and texturizing 13
  Lighting 13
  Rendering 13
**Introduction**

In this beginners guide we discuss how to build a simple humanoid character and how to animate it.

It was not our intention to give a step-by-step guide on how to build a character and how to animate it, because there is extensive amount of literature available on this.

This guide can be used next to the “Learning Maya 5 Foundation” book as a source for more information and explanation. We found that although the book is very clear on what actions to do and what the actions will result in, it lacked somewhat in explaining the meaning of concepts and the reasons for performing actions.

In this guide, we first give an explanation of the Maya interface and the main interface elements that are important for character building and animation.

We then follow the “Learning Maya 5 Foundation” subjects on building and animating a humanoid character. First building the basic character by creating a skeleton, adding geometries, flexors and selection handles. Then preparing the character for animation, by adding controls for movements with expressions, rotate planes and vector constraints. Then animating the character by creating character nodes, keyframes, linear animation, non-linear animation and non-destructive keys (secondary animation) and the Maya Embedded Language (MEL). In the last part we discuss shortly the use of cameras, lighting, texturizing, rendering.
The Interface

Menu Sets
While Maya’s first six menus are always available, the remaining menus change depending on which menu set you choose. This helps focus your work on related tools.

QWERTY Tools
The Qwerty toolbars are used to Select (S), Move (M), Rotate (R), Scale (S), and Show Manipulators (D) as well as access the text tool used (Y) in the scene.

Quick Layout Buttons
The Quick Layout Buttons provide predefined configurations of the Maya workspaces. The Flight Menu Button and the layers will also give access to more options (not available in Maya 2.5.1).

Time Slider
The Time Slider shows you the time range as defined by the range slider, the current time and the keys on selected objects or characters. You can also use the "scrub" through an animation.

Help Line
The Help Line gives a short description of tools and menu items as you scroll over them in the UI. This feature prevents you from being overwhelmed with the steps required to complete a complex tool workflow.

Range Slider
This bar lets you set up the start and end time of the scene’s animation and playback range. If you want to focus on a smaller portion of the timeline.

Status Bar
The Status Bar contains shortcuts for a number of menu items as well as tools for setting up object selection and transformation. A Quick Selection field is also available that can be set up for name-based selection.

Shelf
The Shelf is available for you to set up customized tool sets that can be quickly accessed with a single click. You can set up shelves to support different workflows. Press Shift+Ctrl+Alt when selecting a menu item to add it to the shelf.

Channel Box
The Channel Box selects and key values for selected objects.

Layers
Maya has two types of layers. Display Layers are used to manage a scene, while Render Layers are used to set up render passes for compositing. In each case, there is a default layer where objects are initially placed upon creation.

Playback
The Playback controls let you play the animation as defined by the Time Slider range.

Characters
The Character Menu is used to define one or more characters, then animate them for being animated.

Command Line
This bar has an area for entering and editing MEL commands and can accept the text or the right in MEL scripting language.
Main Shortcuts

Display settings
Display Smoothness Low 1
Display Smoothness Med 2
Display Smoothness High 3
Display Wireframe 4
Display Shaded 5
Display Shaded and Textured 6
Display with lights 7
Open paint panel tool 8

Manipulating Objects
Select tool q
Move tool w
Rotate tool e
Scale tool r
Show manipulator t
Last tool used y
Manipulator display size -, +

Snapping
Snap to Grid x
Snap to Curve (especially nurbs) c
Snap to Point (especially polygons) v

Keying Shortcuts
Set key s
Key all translation attributes Shift + w
Key all rotate attributes Shift + e
Key all scale attributes Shift + r

Camera Navigation
Tumble view Alt + LMB
Track view Alt + MMB
Dolly view Alt + RMB

Edit operations
Undo z
Redo Shift + z
Delete Delete
Repeat last action g
Duplicate Ctrl + d
Duplicate with transform Shift + d
Parent p
Unparent Shift + p

Menu sets
Animation F2
Modeling F3
Dynamics F4
Rendering F5

Selection mask
Toggle object / Component mode F8

Open editor
Attribute editor
Building a Character

Character Animation

In Maya, character animation typically involves the animation of surfaces using skeleton joint chains and inverse kinematic handles to help drive the motion. At the same time the chains can be set up to work with special sculpt objects and lattices known as flexors. These let you perform surface deformations that will add realism to your character.

Building a skeleton using skeleton joints

Skeleton joint chains are hierarchies made up of nodes that are connected visually by bone icons. These hierarchies can be grouped or bind to the geometries that form the actual character. Skeleton joints are used to drive the movement of the geometries and can be used to create surface deformations that can be used to reshape (give a squash or stretch quality to) the geometries.

Drawing a skeleton

In the Animation menu set select Skeleton→Joint Tool. In the option window set the Auto Joint Orient to None. Press the “x” key, then click to place joints (grid snapping) for the hip, the knee, the ankle (leg joints), the ball of the foot and the toe (foot joints) and press Enter to accept.

You can rename the joints by selecting them in the Hypergraph view panel and changing their names in the Channel Box. For the Channel Box, select Display→UI Elements→Channel Box/Layer Editor.

Inverse kinematic (IK) handles

There are two sorts of kinematics used in Maya, forward and inverse. In forward kinematics, the positions of the model at a specific time are calculated from the position and orientation of the object, together with any information on the joints of the model. Inverse kinematics is the process of determining the movements of
interconnected parts of a model. For a complex skeleton animation, forward
kinematics will not suffice. In this guideline we will therefore only cover the inverse
kinematics.

Controlling the motion of an object is done with an IK handle. This is an inverse
kinematics tool. The type of IK solver that you use determines the effect that the IK
handle has on a joint.

If an object may not bend beyond a certain angle, rotate the joint into the maximum
angle you want it to be able to move in, then select Skeleton ➔ Set Preferred Angle.

To create an IK Handle, draw the IK chain by selecting Skeleton ➔ IK Handle Tool
and clicking the two joints that form the start and the end of the movement (IK) chain.

**Adding a geometry to the skeleton**

The geometry gives the actual form to the character.

*Creating a Geometry*

Geometry’s can be created by in the Modeling menu set selecting Create ➔ NURBS
Primitives ➔ <geometry>.

In the Channel Box characteristics for the geometry can be adjusted, such as
Translation, Rotation, Scale, etc. For spheres, cylinders, etc, in the INPUTS Box,
other characteristics such as Radius, Number of Spans and Degree can be adjusted.
The characteristics can also be adjusted by using the mouse (select tool, move tool,
scale tool).

*Binding the Geometry using a Lattice*

Grouping or joining the skeleton joints to the geometry is done so that movement can
be driven. To get nice deformations, a lattice deformer can be used. This deformer
type allows reshaping (deforming of the surface) of one or more surfaces using a
special frame.

*Adding a lattice*

Select the geometry that needs to be deformed. In the Animation menu set, select
Deform ➔ Create Lattice. In the Channel Box edit the shape node attributes.

*Binding the lattice to the geometry*

Select the lattice and the geometry. Also select the point from where the movement
will come (e.g. the skeleton’s hip joint node). Select Skin ➔ Bind Skin ➔ Rigid Bind
. Set Color Joint to on. Click Bind Skin. The joints and bones are now colored
different, which makes it easier to identify membership of control vertices (influence
curves) and lattice points to the bind sets.
Adding flexors to the character

Flexors are special deformers used to make the geometry bend more subtly, like a muscle, instead of getting pinched.

To add a flexor to a joint, select the joint and select **Skin > Edit Rigid Skin > Create Flexor…** In the create flexor window set **Flexor type** to **Lattice** and **Joints** to **At Select Joints.** Click Create then Close.

Duplicating (parts of) the character

Duplication saves you from having to make identical parts twice. You can simply make an object once and copy it.
In Hypergraph, select all the objects you want to duplicate. Select **Edit > Duplicate** – and set **Duplicate Input Graph** to **On.** Click on **Duplicate.** In the Channel Box, rename the joints.

Selection handles

The selection handle is a special marker that makes it easier to pick the group in object selection mode. Selection handles make it easier to find and select the handles that are used to control the skeleton during animation (the whole hierarchy you want to work with).

*Displaying and moving Selection Handles*
In the Perspective view, select **Show > NURB Surfaces** and **Show > Deformers** to turn these off, so you can get a better view of the skeleton. Select **Display > Component Display > Selection Handles** to display the Selection Handles.
To make it easier to select the selection handles, they can be moved outside the object.
This can be done in the Component mode by picking the selections pick mask and moving the handles so they are outside the object.

Expressions

Expressions are instructions that control keyable attributes. You can use expressions to increase the size of an object over time, or to control the position of an object in relation to other objects.
To write expressions go to **Window > Animation Editors > Expression Editor.**
For increasing the size of an object over time (for example the Y scale) an expression would look like: `<name attribute>.scaleY = time + 1`. Entries are case sensitive. Click **Create** then test the expression to see the results.
Rotate plane IK solver rotation

With the IK solver, you write your own inverse kinematics (IK) system. The IK solver determines the orientations of intermediate joints. The rotate plane solver gives you more control over the plane in which you want the movement to take place. Select the IK handle and move the object until just before it makes a wrong movement. Adjust the Pole Vector Axis in the Show Manipulator Tool, by dragging the manipulator handle down. Adjust the Twist Manipulator (circle), to control the rotation.

Vector constraints

Pole Vector constraints are useful because they allow you to control the position of joints and correct unwanted flipping of joints (for example, the elbow) in an IK joint chain by creating an IK solver and controlling it with the pole vector constraint.

Select one or more target objects, followed by the IK rotate plane handle whose pole vector you want to constrain.

Select Constrain→Pole Vector. A pole vector constraint is then created with the current constraint options. (The Add Targets option should be on.) The pole vector's position attributes (Pole Vector X, Y, and Z) are now locked. The target point now provides their values.

Character Nodes

Character nodes are a non-linear animation technique to make the character walk. This is done in the Trax editor. In order for the Trax editor to recognize your character, you need to create Character nodes and Sub-character nodes, which puts the different attributes into one grouped node.

To create a main character node, make sure that nothing is selected, select Character→Create Character Set, name it and click on Create Character Set. To create the sub character, in the Channel Box, select the attributes needed (for the legs: translate, rotate and roll) using Ctrl and select Character→Create SubCharacter Set. Rename and choose the SubCharacter Set Attributes from the From Channel Box.

To change to the character set wanted in the character menu, click on the character name, and while still holding down the mouse button, selecting the character set wanted.

To add attributes to the (sub) character set, In the Channel box, select the attributes wanted (using Ctrl for more then one) and select Character→Add to Character Set. To remove attributes, select Character→Select Character Set Node and then the character wanted, to display all the attributes belonging to that character in the Channel Box. Select the attributes you want to remove and select Character→Remove from Character Set.
Animation: keyframing and positioning

To create a cycle you will need the start position and the end position to be similar. You have to start by choosing a time range. Choose your start and end time, you have to choose the character set that you are going to animate, for example the legs to let the man walk (you can find this right from the time slider). Then you start positioning the figure in the start pose and key this. Maya fills in the motion in between the keys.

The shortcut for “set key” is “s”. Another way to set keys is by using the Auto keyframe toggle button (right side of the time slider), which then automatically sets the keys for you.

Choose Character Set

To refine the in-between motion you can change the animation curves, this can be done in the Graph editor. Before opening the Graph Editor de-select all nodes. In the Graph Editor highlight the character on which you want to refine the motion, then select View ➔ Frame All. Then highlight the curves that you want to refine, select Tangents ➔ Flat (smooth) / Spline (smooth and floaty) / Linear (constant velocity, no acceleration) / Stepped (no animation in between keyframes (good for camera cuts))

When one cycle of for example the walk is finished you can now repeat this motion by setting keys directly or copying and pasting the keys or by using the Trax editor to copy the motions.

Creating a clip

Go to frame 1, make sure that nothing is selected and that the active character menu is set on the character set that you have animated, for example the legs. Set your views to show a Perspective view panel, a Visor panel and a Trax editor panel.

To create a clip, select Animate ➔ Create Clip then name it, leave keys in the timeline to off and clip to put clip in visor only, click Create Clip.

In the visor select the character clips tag, the source of the clip is available there.

Cycling the clip

Click and drag the clip from the visor to the Trax editor, onto the track that the clip belongs to. When you move your cursor to the bottom right of the clip in the Trax editor it changes to a circular arrow and a line. If you drag it to the right you enlarge your clip. You have to set the end time to the time of your clip. When you playback the scene you can see it starts at the beginning over and over. To solve this, double click on the clip in the Trax editor and in the Channel Box change the offset attribute to relative. This places each cycle in relation to the last.
Scaling the clip
When you move the cursor to the top right of the clip in the Trax editor and it changes to a straight arrow and a line you can drag it to the left to make it go faster or to the right to slow it down.

Animating the Character

Non-Linear Animation
Non-Linear Animation is a technique used to re-use linear animation for retiming, looping and other animation effects. Important when putting two clips after each other, is to be sure that the end pose of the first clip and the start pose of the second clip can blend seamlessly with each other. A non-linear blend will not work if you are using relative offsets (clip two starts with the end pose of clip one). A transition clip can be made that uses the ending of the first clip and the beginning of the second clip as absolute poses (single frame clips that can be used as building blocks for more complex clips) that can be blended and then merged into a new clip.

Create start pose of second clip and end pose of second clip.
Select the clip by double clicking. In the Channel Box, set the Offset to absolute. Go to the start frame of the clip, and select Animate→Create Pose. Give the start pose a name in the option window and click Create Pose. Do the same for the last frame of the first clip you want to use. Edit the start pose of the second clip so that the position immediately follows the start pose. Do this by editing the object.translateX keys.

Blend the two poses
To create a softer transition between the two poses, you need to blend them. In the Trax editor, select the two poses and select Create→Blend from the Trax editor menus. This will create a smoother transmission from one pose to another.

Merge the poses into a clip
This is done to make working with the transition easier. Select the two poses and select Edit→Merge from the Trax editor menus. Rename in the Channel Box.

Adjusting the transition clip curves
This is done to make the movements take place more smoothly. Select the transition clip and in the Trax editor select View→Graph Anim Curves.... In the Graph Editor select View→Frame All. To delete all the excess keys resulting from the merge, in the Graph Editor, select all the curves and then select Tangents→Spline. Select all the keys except the two end keys and Delete them with the delete key.

Adjust the timing of the clip
Drag the upper right corner of the clip (in the Trax editor) to scale it to the desired length.
Non-destructive Keys

Non-destructive keys allow you to add some secondary animation to your clips. To do this, make a start and end key, position the object a little different and make another key. The movement will have changed, but the clip has not. The extra movement can easily be moved or removed, by moving or deleting the key.

Animating a Camera and Aim

Camera’s give you control over the view that you want over the scene. Additional nodes allow control over the camera’s position (camera point) and rotation (view point).

To be able to work with the camera, make it visible by selecting **Show ➔ Cameras and Show ➔ Pivots**.

There are three different types of camera’s that can all be made by selecting **Create ➔ Cameras ➔ Camera/Camera and Aim/Camera, Aim and Up**. These three cameras only differ in the way you can control them. Aim gives you a constraint to control what the camera is pointing (looking) at. Up controls where the top of the camera points to and allows the camera to be tilted to left or right. **The Camera, Aim and Up can all be positioned with the Show Manipulator tool. To get the camera view, go to Panels ➔ Perspective ➔ camera.**

To have the camera follow the movements of the character, at the right frame, move the camera in the position you want it to be and use keyframes (**Shift w**) to position the viewpoints.

Maya Embedded Language (Mel)

MEL (Maya Embedded Language) is a scripting language. Everything you can do using Maya’s graphical interface can also be done using MEL. You can use the command line and type your text string to complete a particular action. The **Command line** can be found at the bottom left, under the time slider. Or you can use the **Script Editor** window, which you can open at the bottom right. The Script Editor shows all the commands that have been executed and there is more space to work in then the Command line.

For example if you type **sphere** in the command line and press enter, a sphere will appear in the work area. When you open the Script editor you will see the script that you entered in the command line and what has been executed. You can also use the Script editor to execute your commands, for example to scale and move the sphere you made. You enter the text string: **move 2 2 0; scale 1 5 3**; you have to separate the actions with a semicolon. If you make a mistake while entering commands, an error message appears in the history section.

We are not discussing MEL scripting any deeper, because that is beyond the scope of this tutorial.
Rendering the scene

When your character and animation are set up, you need to apply color and texture before you can render it. This is done using shading groups. In Maya, the appearance of a surface is defined by how it’s shaded. Surface shading is a combination of the basic material of an object and any textures that are applied to it.

Open a Hypershade, a Render view and a Perspective window, turn on hardware texturing Shading→Hardware Texturing in order to see the materials, and you open the Attribute Editor Display→UI Elements→Attribute Editor. The Hypershade panel is made up of three sections as seen below.
Creating and texturizing

You will use the Hypershade and the Attribute editor for this. Before you start you have to clear the workspace, by clicking with your RMB in the work area and select **Graph→Clear Graph**.

To choose a material, select **Create Materials** in the Create menu bar. Choose one of the materials. This will put it in the work area and in the hypershade tab. The attribute editor shows the information of the node, you can rename and edit it there.

When you are finished editing you can assign the material to the object. With your MMB click and drag the material node from the Hypershade panel into the perspective view and drop it on the object.

You can also give the material a texture. After you’ve created a material node, select **Create Textures** in the Create menu bar. This shows a series of icons that can be used to create textures. Select one, the node will appear in the work area. Click with your MMB on the texture node and drag it onto the material node. When you release the mouse button a pop-up menu appears, select **Color** from the menu to map the texture to the material node.

You can also use a texture that you created yourself. In the **Create Textures** list choose the **File icon**. In the Attribute editor, click on the File folder button (next to Image name) and the file that you created.

Lighting

To see what you made you need light, just like in the real world. Select the light source **Create→Lights→** for example **Spot Light**. You get a look at a point and an eye point and you can reposition both with the Show Manipulator tool. To see how the light is affecting the surface, in the Perspective view, set **Lighting→Use All Lights**.

By default shadows are turned off. You can turn shadows on if required. To do this you must select the light, in the Attribute editor open the **Shadows** section and click on **Use Depth Map Shadows**.

Rendering

Before rendering select **View→Camera Setting→Resolution Gate** to see if the camera angle is correct. Make a test rendering by in the Render View panel click with RMB and choose **Render→Render→persp**. If you are happy you can render your animation.

Open the Render Global Setting window by selecting **Window→Rendering Editors→Render Globals….** In the common tab give the file a name, set **Frame/Animation Ext** to name.#.ext, now a numbered sequence of images will be rendered, and you have to set the Start and End frame.
In the Maya Software tab, under motion Blur turn on Motion Blur and set the Type to 2D. This type renders the fastest. Go to the Render menu set (press F5, or in the upper left corner) and select **Render**→**Batch Render**.

After the rendering is completed you can preview the result using the **Start**→**Programs**→**AliasWavefront**→**Maya**→**Fcheck** utility. After opening Fcheck select **File**→**Open Animation** and select the first frame of the rendered work.

*Accept the Maya Challenge!!*